Thursday, 22 August 2013

RE: [U-Boot] dtc: invalid option -- 'i'

> -----Original Message-----
> From: Tom Rini [mailto:[email protected]] On Behalf Of Tom Rini
> Sent: Thursday, August 22, 2013 11:33 PM
> To: Sharma Bhupesh-B45370
> Cc: '[email protected]'; 'u-boot'; 'FengHua'; 'ubuntu-
> [email protected]'
> Subject: Re: [U-Boot] dtc: invalid option -- 'i'
>
> On Thu, Aug 22, 2013 at 05:55:46PM +0000, Sharma Bhupesh-B45370 wrote:
> >
> > > -----Original Message-----
> > > From: Tom Rini [mailto:[email protected]] On Behalf Of Tom Rini
> > > Sent: Thursday, August 22, 2013 6:22 PM
> > > To: Sharma Bhupesh-B45370
> > > Cc: 'u-boot'; '[email protected]'; 'ubuntu-
> > > [email protected]'
> > > Subject: Re: [U-Boot] dtc: invalid option -- 'i'
> > >
> > > On Thu, Aug 22, 2013 at 07:11:39AM +0000, Sharma Bhupesh-B45370
> wrote:
> > >
> > > > Hi List,
> > > >
> > > > I am using a 64-bit ubuntu machine running a 12.04 LTS.
> > > > I see that the DTC (Device Tree Compiler) version is 1.3.0
> > > >
> > > > $ dtc -v
> > > > Version: DTC 1.3.0
> > > >
> > > > When I try to compile the latest u-boot 'master' branch (updated
> > > > yesterday), I get the following error with dtc:
> > > >
> > > > dtc: invalid option -- 'i'
> > > >
> > > > followed by a Usage suggestion.
> > > >
> > > > I checked that a newer DTC version 1.4.0 is available from Linaro,
> > > > but I can't find an updated version for ubuntu and apt-get returns
> > > > me a
> > > message:
> > > >
> > > > device-tree-compiler is already the newest version
> > > >
> > > > Any pointers to what I could be doing wrong here?
> > >
> > > What target are you building for as it should have run the 'checkdtc'
> > > rule and told you that you need to install DTC 1.4.0. And yes for
> > > Ubuntu you'll need to build your own.
> > >
> >
> > Hi Tom,
> >
> > I am trying to build the new support code of ARMv8 (using patches from
> > David Fengua), using:
> >
> > $ make vexpress_aemv8a
>
> Ah, OK, I'll make sure that it invokes the checkdtc rule as well.
>
> > I will try building a DTC 1.4.0 for u-buntu by myself, but if we are
> > saying that latest u-boot requires DTC 1.4.0 to work well, aren't we
> > breaking u-boot compilation on older systems like ubuntu/fedora which
> > have older DTC versions?
>
> We are, quite intentionally. I should have spelled it out in the -rc1
> release notes, but certainly will in the v2013.10 release itself. We've
> wanted to do these changes for a while (as the rules for invoking dtc got
> quite complex for handling all the versions) but were able to get a new
> release out of upstream before changing things around. FWIW,
> Fedora/related has packages available.
>

I believe some mention of this limitation in the release note would have been
great. Yes, fedora has newer packages available, but ubuntu is still adding
1.4.0 DTC support (to newer versions) and I don't know what are the timelines to back-port it
on LTS releases like 12.0.4

Thanks for your help.
Regards,
Bhupesh


--
ubuntu-devel mailing list
[email protected]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel