Monday, 6 April 2015

Re: Status: Python3 only on the ubuntu-desktop images

On 04/07/2015 01:28 AM, Matthias Klose wrote:
> Before leaving for PyCon and with 15.04 beta2 released, I had a look at removing
> Python2 from the desktop images. We are not there yet, but it looks promising
> and realistic to achieve for 15.10. Bugs can be seen at
>
> https://bugs.launchpad.net/ubuntu/+bugs?field.tag=python3

sorry, hit Send before finishing ...

- some more applications are still using Python2. software-center,
deja-dup, duplicity.

- upstream is wary to support bindings for both 2.7 and 3.4,
looking for alternative solutions

- ibus and libpeas have packages both depending on 2.7 and 3.4.
these probably should be split.

- the rest are "mostly" scripts.

Please reply to particular issues directly in the bug reports.

Matthias


ubuntu-sso-client
enough of Twisted ported to Python3?
1037768, 1035104

software-center
823254
all dependencies are available

update-notifier
partly ported?
1440683

sessioninstaller
recommended by file-roller and software-center
porting to python3 doesn't look too bad
1440368

landscape-client (landscape-client-ui-install)
one script ... 1440366

apt-xapian-index
recommended by software-center
needs python3-xapian, which will get usable with xapian-bindings 1.4 (not yet
released).

deja-dup (seeded as a recommends)
1440370 needs porting

duplicity (dep of deja-dup)
1440372 partially ported

zeitgeist
dependency of activity-log-manager (seeded as a recommends)
1440373
supported upstream, build a python3-zeitgeist package and let zeitgeist depend
on it

oneconf (dependency of software-center)
oneconf-common should use python3 by default
1440375

totem-plugins
recommends of totem (seeded)
1440377, upstream supported

tdb
nautilus-share (seeded as recommends)
1440379, seems supported upstream

samba (needed by gvfs-backends) -> removal of system-config-printer
python3-samba needed
1440381

talloc (needed by samba-libs)
python3-talloc needed
1440384

pidgin/libpurple-bin
1440390
seems to be supported upstream

ubuntu-system-service
1440388

oneconf
oneconf-common should use Python3 by default
1440375

zeitgeist
1440373
build a python3-zeitgeist package and let zeitgeist depend on it

ibus:
1440391
gir1.2-ibus-1.0 depends on both libpython2.7 and libpython3.4.

strange dependency on python-notify, while it otherwise only
has dependencies on python3. is a python3-notify package needed?
Fixed. upstream dropped pynotify in 2008, not fixed in the
packaging. Now even demoted.

libpeas
1440504
runtime library package depends on both libpython2.7 and libpython3.4.

compiz/compiz-gnome
dependency on python
/usr/share/session-migration scripts
1440548

gconf/gconf2
1440549
two python scripts

plainbox-provider-checkbox
1440553
python scripts

rastertosag-gdi
1440554
python script

unity
1440560
/usr/share/session-migration scripts

webapps-applications
1440561
/usr/share/session-migration scripts

xdiagnose
1440564
some scripts not converted


--
ubuntu-devel mailing list
[email protected]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel