Thursday, 20 August 2015

Re: gnupg 2.1.x by default

On 20 August 2015 at 11:28, Dmitry Shachnev <[email protected]> wrote:
> Hi Dimitri,
>
> On Sat, 11 Jul 2015 22:49:40 +0100, Dimitri John Ledkov wrote:
>> I'd like to propose to switch to gnupg 2.1.x by default.
>>
>> [...]
>> How does above plan sounds? Any comments / remarks / suggestions?
>
> I am now successfully running gpg2 by default on one of my laptops
> (first 2.0, then 2.1) for a couple of weeks.
>
> I fully support the switch because I got used to GNOME graphical
> password prompts, and they now no longer work with gpg 1.x.
>
> I had to fix some packages' configuration (mainly devscripts/debsign
> and git) because they use /usr/bin/gpg by default.
>
> python-gnupg does not currently support 2.1 (but supports 2.0),
> that is fixed in upstream hg and hopefully there will be a new
> release soon.


cool, but it is feature freeze today.

So, i'll prepare a PPA for wily with 2.1 as default, and we will aim
at 2.1 only for next cycle. This should give us plenty of time to
prepare, and have e.g. gpg 2.1 as default at the Xanthous Xuangui
opening.

--
Regards,

Dimitri.

--
ubuntu-devel mailing list
[email protected]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel