Monday, 21 March 2016

Re: Only one qt version on the Ubuntu Desktop iso?

On Fri, Mar 18, 2016 at 07:13:34PM +0100, Dmitry Shachnev wrote:
> […]
> sni-qt can definitely be a Recommends of libqtgui4, it is useful on other
> desktops too (i.e. Plasma or Xubuntu).

Please do this.

>
> fcitx-frontend-qt4: I don't think it has anything Unity-specific, and
> also most of the users don't need it, so can be a suggestion of libqtgui4.

Hmm. That would be quite unfortunate for users that *do* need it. We
discussed this on #ubuntu-desktop a few weeks ago, and back then I
suggested using language-selector to install this for users who have
fcitx installed. data/pkg-depends contains:

> # Column 3: dependency package(s). Only install the package in column 4 when this dependency package is already installed.

so there is the basics of what we need. We'd need some development to
trigger check-language-support as appropriate to install this.

Not fixing this part right now still lets us get Qt4 out of the default
installation IIRC - but it would still be on the desktop ISO for the
'live' task support that we worked on last(?) cycle.

>
> So we are down to appmenu-qt. It's tiny (the only non-Qt dependency is
> libdbusmenu-qt4) so probably it can be a recommendation of libqtgui4 too.

Please do this one too.

Cheers,

--
Iain Lane [ [email protected] ]
Debian Developer [ [email protected] ]
Ubuntu Developer [ [email protected] ]