Monday, 18 July 2016

Re: Re: OpenGL to OpenGL ES change on arm64?

2016-06-06 5:23 GMT+03:00 张超 <[email protected]>:
> Hi All,
> We have ARM64 devices used AMD Radeon Series graphics cards。So,same as x86
> we really need a full OpenGL Qt support With ARM64 。

Hi. I noticed this e-mail went unanswered. All Radeon graphics (and
NVIDIA) run OpenGL ES applications fine, so it's not strictly a
requirement. It's the OpenGL ES GPUs that are the majority use case on
armhf/arm64 that do not support traditional OpenGL and its legacy
features all the way from 1991. OpenGL ES 3.1 does support most of the
advanced features of OpenGL 4.5, so applications should be possible to
be made OpenGL ES compatible regardless of how advanced features they
use.

In the long run, upstream does have a bug open to make the switch
between OpenGL and OpenGL ES run-time selectable, like it already is
on Windows.

-Timo

--
ubuntu-devel mailing list
[email protected]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel