Tuesday, 27 December 2016

Re: Call for testing : Driverless printing on Zesty

Thanks for the quick reply.

I had to install cups-ipp-util first, then avahi-discover.

Here are the output of the commands:
---------------------------------------------------------
[email protected]:~$ driverless list
DEBUG: Started ippfind (PID 1317)
DEBUG: Started post-processing (PID 1318)
"driverless:ipp://BRW3C77E657AB52.local:631/ipp/print" en "Brother" "Brother MFC-J650DW, driverless, cups-filters 1.13.1" "MFG:Brother;MDL:MFC-J650DW;CMD:PWG,URF,JPEG;"
DEBUG: PID 1317 (ippfind) exited with no errors.
DEBUG: PID 1318 (Post-processing) exited with no errors.
---------------------------------------------------------
avahi-discover

I selected entry Brother MFC-J650DW from the Internet Printer list:

Type de service : _ipp._tcp
Nom du service : Brother MFC-J650DW
Nom de domaine : local
Interface : enp1s0 IPv4
Adresse : BRW3C77E657AB52.local/192.168.179.107:631
TXT Binary = T
TXT Duplex = T
TXT Copies = F
TXT product = (Brother MFC-J650DW)
TXT priority = 25
TXT Fax = T
TXT rp = ipp/print
TXT ty = Brother MFC-J650DW
TXT PaperCustom = T
TXT note = Bureau
TXT adminurl = http://BRW3C77E657AB52.local./net/net/airprint.html
TXT print_wfds = T
TXT txtvers = 1
TXT Transparent = T
TXT usb_CMD = HBP,BRPJL,URF
TXT URF = SRGB24,W8,CP1,IS1,MT1-8-11,OB9,PQ4-5,RS300,OFU0,V1.2,DM3
TXT usb_MDL = MFC-J650DW
TXT qtotal = 1
TXT usb_MFG = Brother
TXT UUID = e3248000-80ce-11db-8000-3c77e657ab52
TXT Scan = T
TXT Color = T
TXT pdl = application/octet-stream,application/vnd.brother-hbp,image/pwg-raster,image/urf,image/jpeg
TXT TBCP = F

----------------------------------------------------------

I checked my printer setup with a browser and AirPrint is active.

I tried to setup the printer with /usr/bin/system-config-printer and  I had the choice between 3 protocols for the same printer :
  • ipp://BRW3C77E657AB52.local:631/ipp/print
  • lpd printer BRW3C77E657AB52
  • Network printer via DNS-SD for ipp://BRW3C77E657AB52.local:631/ipp/print
I choosed the first one, and this time I had a message saying "Searching for driver" and it did not prompt me with the usual list of all printers that it knows, but it ask me for the name of the printer and a name for the place it is.   I printed the "Printer test page" and everything works OK now.

Thanks a lot for the help.  I don't know exactly why CUPS was asking for information to select the driver from its list and now it doesn't anymore ?

But it works great! 

   Regards,
                Bernard


2016-12-27 20:38 GMT-05:00 Till Kamppeter <[email protected]>:
[ Re-posting to ubuntu-devel mailing list ]

Please check whether you have the up-to-date versions of CUPS and cups-filters:

----------
[email protected]:~$ dpkg -l | grep cups
ii  cups 2.2.1-46-g10887d272-2                       amd64        Common UNIX Printing System(tm) - PPD/driver support, web interface
ii  cups-browsed                                         1.13.1-1                             amd64        OpenPrinting CUPS Filters - cups-browsed
ii  cups-client 2.2.1-46-g10887d272-2                       amd64        Common UNIX Printing System(tm) - client programs (SysV)
ii  cups-common 2.2.1-46-g10887d272-2                       all          Common UNIX Printing System(tm) - common files
ii  cups-core-drivers 2.2.1-46-g10887d272-2                       amd64        Common UNIX Printing System(tm) - PPD-less printing
ii  cups-daemon 2.2.1-46-g10887d272-2                       amd64        Common UNIX Printing System(tm) - daemon
ii  cups-filters                                         1.13.1-1                             amd64        OpenPrinting CUPS Filters - Main Package
ii  cups-filters-core-drivers                            1.13.1-1                             amd64        OpenPrinting CUPS Filters - PPD-less printing
ii  cups-ipp-utils 2.2.1-46-g10887d272-2                       amd64        Common UNIX Printing System(tm) - IPP developer/admin utilities
ii  cups-ppdc 2.2.1-46-g10887d272-2                       amd64        Common UNIX Printing System(tm) - PPD manipulation utilities
ii  cups-server-common 2.2.1-46-g10887d272-2                       all          Common UNIX Printing System(tm) - server common files
ii  libcups2:amd64 2.2.1-46-g10887d272-2                       amd64        Common UNIX Printing System(tm) - Core library
ii  libcupscgi1:amd64 2.2.1-46-g10887d272-2                       amd64        Common UNIX Printing System(tm) - CGI library
ii  libcupsfilters1:amd64                                1.13.1-1                             amd64        OpenPrinting CUPS Filters - Shared library
ii  libcupsimage2:amd64 2.2.1-46-g10887d272-2                       amd64        Common UNIX Printing System(tm) - Raster image library
ii  libcupsmime1:amd64 2.2.1-46-g10887d272-2                       amd64        Common UNIX Printing System(tm) - MIME library
ii  libcupsppdc1:amd64 2.2.1-46-g10887d272-2                       amd64        Common UNIX Printing System(tm) - PPD manipulation library
[email protected]:~$
----------

If you have older versions, please run a system update.

Please run the following command:

driverless

This should show an entry for your printer, starting with "ipp".

If not, run

ippfind

Does your printer have an entry here?

If not, open the web administration interface of your printer, opening

http://<IP or host name of your printer>/

in a web browser. Go into the network settings and make sure that IPP support and/or AirPrint is enabled.

Do

sudo apt-get install avahi-discover

and then run

avahi-discover

Look for your printer. It should be available under your standard network interface (usually "eth0" or "wlan0"), IPv4, and there under "Unix Printer" and "Internet Printer". Click on its "Internet Printer" entry. Then you will see some data about it in the lower part of the window and the data also appearing in the terminal window from which you started avahi-discover, something like this:

----------
Service data for service 'Deskjet 2540 series [E7DDC7]' of type '_ipp._tcp' in domain 'local' on 3.0:
        Host HP5CB901E7DDC7.local (192.168.223.1), port 631, TXT data: ['Scan=T', 'Duplex=F', 'Color=T', 'UUID=1c852a4d-b800-1f08-abcd-5cb901e7ddc7', 'Fax=F', 'note=', 'adminurl=http://HP5CB901E7DDC7.local./#hId-pgAirPrint', 'mac=02:ba:d0:3f:7f:fe', 'priority=20', 'usb_MDL=Deskjet 2540 series', 'usb_MFG=HP', 'product=(HP Deskjet 2540 series)', 'ty=Deskjet 2540 series', 'URF=CP1,MT1-2-8-9-10-11,OB9,OFU0,PQ3-4-5,RS300-600,SRGB24,W8-16,DEVW8-16,DEVRGB24-48,ADOBERGB24-48,IS1,V1.3', 'kind=document,envelope,photo', 'PaperMax=<legal-A4', 'rp=ipp/print', 'pdl=application/vnd.hp-PCL,image/jpeg,application/PCLm,image/urf', 'qtotal=1', 'txtvers=1']
----------

Please post what you get for your printer.

It should have "image/urf" in the "pdl=..." part and it should have a "URF=..." part.

Please post the output of all commands in your reply. Thanks.

   Till


On 12/27/2016 11:01 PM, Bernard Tremblay wrote:
Sorry to email directly, I'm new on the ubuntu-devel list. I have
installed ubuntu-mate 17.04 and tried to setup a driverless printer
according to your following post
https://lists.ubuntu.com/archives/ubuntu-devel/2016-December/039586.html

I have a brother printer MFC-J650DW and it is listed in the
support.apple.com <http://support.apple.com> list of printers that
should be able to do "airprint".

I have changed my cups-browsed.conf file and restart services.  I can
see my printer if I try to add a printer.  But I can't set it up without
being asked for the driver.   I tried too with cupsd on the localhost
with same result.

The OS is updated from today dec 27th 19:57 Eastern time.
 uname -a
Linux ungava 4.9.0-11-generic #12-Ubuntu SMP Mon Dec 12 16:18:23 UTC
2016 x86_64 x86_64 x86_64 GNU/Linux

Should I wait for some other update before it starts to work ?  Is it
normal ?


Regards,




--