Tuesday, 25 July 2017

Re: The transition to add support for Python 3.6 is beginning

On Tue, Jul 25, 2017 at 10:37:10AM +0500, Khurshid Alam wrote:
> > We've fixed many of these now, and I've uploaded the change to make
> > python 3.6 the default version in artful. Next step is getting this to
> > migrate, see http://people.canonical.com/~ubuntu-archive/proposed-migration/artful/update_excuses.html#python3-defaults
> > for that and please help fix anything that is preventing the migration
> > (like whatever it is that breaks botch with python 3.6 as default...)

> If I try to update from 3.5 to 3.6 (python3 & python3-minimal package), it
> tries to REMOVE following packages:

<snip>

> Which basically removes everything. So How do I perform update without
> reinstalling the iso? Any idea?

By waiting until this transition has landed in the artful release pocket.
No packages are guaranteed to be installable using the -proposed pocket at
any given point, and you should absolutely not be trying to upgrade a
desktop install against the -proposed pocket.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
[email protected] [email protected]