Monday, 4 September 2017

Re: Old Firefox versions discourage real-world testing of Ubuntu development versions

On Mon, Sep 04, 2017 at 08:50:38PM +0100, Chris Coulson wrote:
> > *Ubuntu MATE ships PowerPC 16.04 images and Raspberry Pi 3 images as well.

> There hasn't been a Firefox update on PowerPC on any release since June
> 2016 (it's stuck on 47.0), and there isn't going to be any more Firefox
> updates on PowerPC because we don't have the rust compiler building there.

Note that the current build failures in artful-proposed are on armhf and
ppc64el, not armhf and powerpc (powerpc is not a built architecture at all
in 17.10).

If the Desktop Team is not taking responsibility for fixing the firefox
build on these architectures, then they should file a bug requesting removal
of the old binaries and subscribe ~ubuntu-archive.

Such a removal request should also account for the reverse-dependencies
shown in the output of 'reverse-depends src:firefox -a armhf' and
'reverse-depends src:firefox -a ppc64el'.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
[email protected] [email protected]