Monday, 12 March 2018

Re: zstd compression for packages

On Mon, Mar 12, 2018 at 02:19:18PM +0000, Colin Watson wrote:
> On Mon, Mar 12, 2018 at 10:02:49AM -0400, Jeremy Bicha wrote:
> > On Mon, Mar 12, 2018 at 6:06 AM, Julian Andres Klode
> > <> wrote:
> > > We are considering requesting a FFe for that - the features are not
> > > invasive, and it allows us to turn it on by default in 18.10.
> >
> > What does Debian's dpkg maintainer think?
> FWIW, I'd be quite reluctant to add support for this to Launchpad until
> it's landed in Debian dpkg/apt; a future incompatibility would be very
> painful to deal with.

Acknowledged. I don't think we want to go ahead without dpkg upstream
blessing anyway. On the APT side, we don't maintain Ubuntu-only branches,
so if we get a go-ahead it would land in Debian immediately too.

I had a quick look at Launchpad and I think it only needs a backport of
the APT commits to an older branch (or an upgrade to bionic, but that
sounds like more work :D) but I might be wrong.

I think the format is versioned and there might be new versions eventually,
so we might have to take care eventually to only keep generating files
in an old format, but xz has the same problem.

debian developer - | - free software dev
ubuntu core developer i speak de, en

ubuntu-devel mailing list
Modify settings or unsubscribe at: