Friday, 24 August 2018

python3-numpy depending on *both* python 3.6 and 3.7


while investigating some DEP8 failures currently in cosmic's
migration, I came across this:
$ dpkg -s python3-numpy|grep Depends
Depends: python3 (<< 3.8), python3 (>= 3.6~), python3.6:any,
python3.7:any, python3:any (>= 3.3.2-2~), libblas3 |,
libc6 (>= 2.27), liblapack3 |

Is it ok/correct to depend on two python versions like that? Is the
point of it making sure numpy is available regardless which python 3
you are using? But at the cost of pulling in both?

This is breaking python3-libcloud, which does not support python3.7,
when pulled in via fdroidserver:

The correct fix is to have python3-libcloud work with python 3.7, by
replacing "async" (a reserved keyword in python3.7) with something
else, like async_, but what caught my eye was this numpy dependency in
two python versions. And how libcloud ended up chosing 3.7 over 3.6
I'm not sure.

ubuntu-devel mailing list
Modify settings or unsubscribe at: