Friday, 17 July 2020

+1 maintenance status − July 13-17

This was my week and here is some of my notes about achievements and highlights:

Overall status:

- read all the maint+1 docs and @piloted in ubuntu-devel

- qemu TCG memory issue causing spinned qemu instances to be killed

casper has a qemu instance killed because of TCG (cdrom file cant be found)

=> lost some time here trying to reproduce, unfortunately lack of attention as @paelzer had already warned me about, but I did not link cause and effect for this case.

open-iscsi - likely same thing
systemd - likely same thing
ubuntu-image - likely same thing

- nettle (lots of implicit dependencies):

blocking curl,

will unblock lots of stuff when fixed.

- sqlite3 blocked by python3.8 and seqtools -> should unblock now

Detailed information of what I remembered to take notes of:

Excuses [main]: pam (armhf kopano-core / amd64 systemd)

FTBFS [main]: zsys (armhf)

Opened an issue for armhf regression: and informed what seemed to be the reason (suggesting arch support or binary package removal)

Excuses [main]: openldap (armhf kopano core)

Retried test (kopano armhf regression similar to pam, which migrated after retry).

Excuses [main]: open-iscsi (amd64 regression)

Christian told me that TCG needs more memory for tests to pass. He has been discussing with upstream about this issue and there is already an available patch. I think he also proposed a mitigation to CI infrastructure.

Excuses [main]: lintian (all lintian regression)

Tried to reproduce the issue locally but couldn't. Tried to reproduce the issue with arm64 (--onlyrun="test:bin-sbin-confusion-in-elf") like logs from qa runs but could not. Re-tried all arches with all-proposed=1. Needs checking.

Excuses [main]: curl (amd64 hyphy regression)

Retried test to see if it passes. Curl still depends on nettle but hyphy has passed.

Excuses [main]: libgpg-error (amd64 systemd regression)

libgpg-error: amd64 regression because of systemd dependency/autopkg tests. It has an "upstream" set of tests and it had stderr (most likely) -> retried.

Investigating casper issue happening in autopkgtest environment only regarding missing cdrom-fstype.txt file.

Excuses [main]: systemd (armhf seqtools)

My seqtools fix unlocked (or will unlock) this.

Excuses [universe]: sqlite3 (armhf seqtools)

The issue is on test4 and happens because of xvfb-run (Xvfb) and not because of the test itself. Checking if there is a fix or we should just make as badtest.

Uploaded a change to seqtools that change resolution for xvfb so tests don't fail in armhf (tested and worked several times).

Excuses [universe]: dropbear (helping sergiodj in ramping up maint+1)

4 hands with sergiodj for maint+1 and core-dev skills ramp up.
(he will send his notes)

Excuses [universe]: python-tz (armhf python-certbot)

Re-tried test to see if it passes. It cant migrate because it would make python-oops uninstall able (regression is gone)

Excuses [main]: sqlite3 (all python3.8 regression)

sqlite3: python3.8 regression in all arches

sqlite3: re-tried hyphy amd64 regression test (illegal instruction executed) => passed.

Python3.8 was updated by doko, I re-tried all tests with the proper version before excuses were updated.

If python3.8 passes (for sqlite3) it shall migrate as I have already fixed .