Friday 7 June 2024

+1 Maintenance Report

I did +1 maintenance from 2024-06-03 to 2024-06-07.

I start the week by running the ubuntu-archive-tools find-proposed-cluster
script. There was nothing relevant there at this point of the cycle.

Then I started looking at individual packages, no hard rules, but I was
trying to focus on the bottom half of the list. Coincidently, the first
2 packages I looked at had infrastructure related failures. I then
proceeded to run the archive tools retry script:

./retry-autopkgtest-regressions --log-regex='unexpected eof from the testbed'

I sticked to this regex for the 5 days I was working on +1 maintainance and
found dozens of (non-duplicated) occurrences each day.

On Thursday and Friday, mirespace was shadowing me during my +1 shifts as our
timezone differences allowed (I suppose she will reply to this thread with her
findings later).

Below are comments on individual packages I worked on throghout the week (not
including test retries).

## qiime and q2-* packages
qiime was blocking several q2-* packages. They all had the same python 3.12
compatibility issue. I add a short patch to each of them and forwarded them
all to Debian as well. Below are the packages cleared (or in their migration
process) from the migration list. If any of those are still in the excuses
page, they are most likely waiting to be accepted from the new queue or
waiting on a dependency which is pending in new.
quiime, q2-phylogeny, q2-types, q2-feature-table, q2-dada2, q2cli, q2-taxa,
q2-quality-filter, q2-metadata, q2-fragment-insertion, q2-feature-classifier,
q2-diversity-lib, q2-demux, q2-cutadapt, q2-alignment, q2-quality-control,
q2-emperor, and q2-sample-classifier

## ruby-toml and ruby-parslet
This is related to
Here, we applied an upstream fix to ruby-toml and re-triggered ruby-parslet
tests. Both packages migrated.

## wannier90
This also had python 3.12 compatibility issues. We uploaded a fix and
forwarded it to Debian.

## python-awkward
We sent a fix to the debian maintainers so it would no longer use internet
connections during the package build. The package is still needing some
fixes, so I did not upload it to Ubuntu (it would most likely migrate, I am
unsure if we want it to migrate as is).

## edflib
Upstream does not support big endian architectures. I applied a patch
available in Debian's salsa to avoid building to s390x and asked the
ubuntu-archive team to remove it from s390x. This was done and the package

## node-yarnpkg
This was an interesting one. The package initially FTBFS due to issues with
"-Bsymbolic-functions". However, removing the flag from the build got us into
a different FTBFS issue also affecting Debian
( This happens
because the off_t type is being configured to be 72-bit long by cmake. After
some investigation and a pair debugging session with sergiodj (thanks,
Sergio), we found out that the build of an embedded library injects a hook
into cmake to call "node" (JS) with the "--experimental-wasm-threads" option.
This option has been removed from node 20 and node now exits with code 9 on
errors. This error code ends up being picked up by the embeded library cmake
checks which ends up being set as the size of off_t (9 bytes). I reported
this to Debian and filed LP: #2068769

## pytorch
pytorch FTBFS with llvm-18. This was already reported last week. there are
several other packages blocked on this. I found some more upstream patches
related to the issue but we are still getting (different) build failures
there. See LP: #2067720.
These are the packages directly blocked by pytorch: tabnet,
pytorch-geometric, baler, open3d, pytorch-ignite, pytorch-cuda,
pytorch-sparse, pytorch-cluster, pytorch-scatter, pytorch-text,
pytorch-vision, and skorch

## python-lsp-ruff
missing python3-ruff (provided by ruff), which was added to the
sync/blocklist due to missing rust-clearscreen. This is now in the archive
and we should sync ruff back in. I tried sync'ing it with

$ syncpackage -r oracular-proposed -d unstable -v --force ruff
$ copy-package -b -s noble --to-suite oracular-proposed -y -e 0.0.291+dfsg1-3 ruff

Both commands reported successful status, but it seems I have no permissions
to copy packages in that exclusion list (?).

Athos Ribeiro

ubuntu-devel mailing list
Modify settings or unsubscribe at: