Sunday, 17 November 2013

Re: libqt4-opengl-dev: Different dependencies on armhf than on other architectures

Andreas Moog <[email protected]> wrote:
>Hi there,
>
>I have a question about the package libqt4-opengl-dev on the armhf
>architecture (source: qt4-x11). I was investigating
>https://bugs.launchpad.net/bugs/941062, a build failure of the package
>fracplanet and was wondering why it succeeded on all other arches as
>well as on armhf in Debian.
>
>The difference I found was in the dependencies of libqt4-opengl-dev:
>
>On amd64 (and others) it is:
>
>Depends: libgl1-mesa-dev | libgl-dev, libglu1-mesa-dev | libglu-dev,
>libqt4-dev (= 4:4.8.4+dfsg-0ubuntu19), libqt4-opengl (=
>4:4.8.4+dfsg-0ubuntu19)
>
>But on armhf in Ubuntu (NOT in Debian):
>
>Depends: libgles2-mesa-dev | libgles2-dev, libqt4-dev (=
>4:4.8.4+dfsg-0ubuntu19), libqt4-opengl (= 4:4.8.4+dfsg-0ubuntu19)
>
>Is there a reason for this difference? How would I go to further find
>out why this is what it is?

In Ubuntu we only support GLES on arm for performance reasons. This is an intentional difference with Debian.

Scott K


--
ubuntu-devel mailing list
[email protected]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel