Thursday, 15 May 2014

Re: errors.ubuntu.com and upgrade crashes

Hi Brain,

On Thu, May 15, 2014 at 10:33:41AM -0700, Brian Murray wrote:
> > I sometimes saw "the" resolved stacktraces where the linenumbers were off
> > for the version of the source I was looking at -- but then again this has
> > to be expected when there are different versions affected by the same crash
> > (Im blissfully ignorant about how apport matches those as "the same" though
> > anyway).
>
> I'm interested in seeing an example of the problem.

just from the example at:

https://errors.ubuntu.com/problem/bda799f20f10ae894860492e0a597fdea476ee5d

you see the presented stacktrace is for libreoffice-4.2.3.3, but there are
reports for this stacktrace back to 1:4.0.2-0ubuntu1. If you just look for the
line of the top frame (vcl/source/gdi/outdev3.cxx:957) in that version its at:

https://gerrit.libreoffice.org/gitweb?p=core.git;a=blob;f=vcl/source/gdi/outdev3.cxx;h=f7640f8ba20452902af59123104d47c8e24cf5ae;hb=4c82dcdd6efcd48b1d8bba66bfe1989deee49c3b#l957

and that is obviously (and expectedly) not the real thing. As said, Im ignorant
of how stacktraces from such different versions are actually mapped to be "the
same problem".

Best,

Bjoern


--
ubuntu-devel mailing list
[email protected]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel