Wednesday, 28 May 2014

Re: [ubuntu/utopic-proposed] apache2 2.4.9-1ubuntu2 (Accepted)

On Wed, May 28, 2014 at 01:53:19PM +0200, Matthias Klose wrote:
> This is not the way to "fix" issues. You are only hiding the issue
> and hoping that it won't be your responsibility to fix it properly. I
> kindly remind you at the mysql-5.5 "fix" to fall back to an earlier
> GCC version and blocking the demotion of gcc-4.4 for two or more
> release cycles.

Regressing apache2 lua support completely by changing the build-dep to
liblua5.2-dev but not verifying that the configure script actually picks
it up isn't "fixing" the issue either. Instead, I have tried to be
constructive by un-regressing apache2 and filing bug 1324062 to track
the need for lua 5.2 support.

Depending on importance and regression risk (of which I'm not sure yet),
I may end up spending time SRU-ing lua support back into Trusty.
Regressing existing support like this is not helpful, and just wastes
the time that you'd like me to spend on lua 5.2.

I also asked you directly in #ubuntu-devel first before reverting this
change, and you did not object. And just to be sure, I did ask somebody
else first.

I fixed mysql-5.5 properly when asked, and had nothing to do with having
it fall back to an earlier gcc version that was done previously, so
please don't pin that on me.

I'm not sure how much I feel any kind of responsibility to work on and
push new lua 5.2 apache2 support upstream. I'd love to do it, but
without upstream or any other distro support I don't see it as a
priority while I'm wearing my Ubuntu hat, when I am spending my time
buried in the server team triage queue with user-affecting
Ubuntu-specific bugs instead, and to my knowledge there is no Ubuntu
user who has actually made himself known as needing lua 5.2 support
(over 5.1) in Apache yet.

Perhaps this is the wrong attitude. If it is, I'd love to hear good
reasons to alter my priorities, and will be happy to change them.