Wednesday, 12 August 2015

Re: Qt 5.5.0 - bug fixing needed

2015-07-15 17:31 GMT+03:00 Timo Jyrinki <[email protected]>:
> Qt 5.5.0 is testable on wily from
> https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/landing-012/
> - including the new Qt 3D tech preview.

It's still there and now fixed to build against GCC5 so brave ones can
again use wily + that PPA. At this point it's safe to say Qt 5.5 won't
be in 15.10 by the next week's Feature Freeze, and will need either an
FFe or target to wily+1. Currently I've not had much requests to get
5.5 in, but at least the Qt 3D would be very interesting to have.

Bug fixing via https://bugs.launchpad.net/bugs/+bugs?field.tag=qt5.5
has been slow. New bugs are also being found and at the moment there's
a new blocker that prevents testing the PPA on a phone. I will keep
https://wiki.ubuntu.com/Touch/QtTesting updated regarding the status.
The PPA is usable in eg a chroot to fix any build problems.

Debian is also still in the middle of the GCC5 transition and I'd like
to always sync from Debian instead of temporarily forking the
packaging, even if I've now moved a lot of the Ubuntu packaging to
Debian git.

On the plus side, we're on track to delivering Qt Creator 3.5 RC1 and
the refactored Ubuntu plugin soon. A lot of the features in Ubuntu's
Qt Creator were upstreamed during the 3.5 cycle and now also the
Ubuntu specific plugin is more streamlined.

-Timo

--
ubuntu-devel mailing list
[email protected]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel