Tuesday, 10 November 2015

Re: ANN: autopkgtests are now specific for "triggering" package for better isolation

On Tue, Nov 10, 2015 at 02:16:39PM -0700, Adam Conrad wrote:
> On Tue, Nov 10, 2015 at 09:31:54AM -0800, Steve Langasek wrote:
> >
> > That works for a silo, because with a silo you want to install *all* of the
> > packages from the ppa together, and pull any additional dependencies from
> > the main archive. For -proposed, we explicitly want to pick and choose
> > *which* packages we are pulling from -proposed vs. the release pocket,
> > because -proposed always contains multiple unrelated "landings" at the same
> > time and we want to be able to disambiguate the test results so we know
> > which package introduces the regression.
>
> Robert's still on the right track here, though. This is just poor use of
> pinning. See the following:

And a better example. Note that you can achieve the same thing with a
990 pin on the xenial-proposed versions of the binaries you want to
install and test instead of using /xenial-proposed.

In this example, we have a library that is in the dep chain and exists
in both release and proposed. You can see that it's installed from
release, and only the packages xserver-xorg has a VERSIONED dep on get
pulled in from proposed:

(wily-amd64)[email protected]:~# cat /etc/apt/preferences.d/10adt-pinning
Package: *
Pin: release a=xenial
Pin-Priority: 900

Package: *
Pin: release a=xenial-proposed
Pin-Priority: 800
(wily-amd64)[email protected]:~# apt-cache policy libxcb-sync1
libxcb-sync1:
Installed: (none)
Candidate: 1.11-0ubuntu1
Version table:
1.11.1-1ubuntu1 0
800 http://us.archive.ubuntu.com/ubuntu/ xenial-proposed/main amd64 Packages
1.11-0ubuntu1 0
900 http://us.archive.ubuntu.com/ubuntu/ xenial/main amd64 Packages
(wily-amd64)[email protected]:~# apt-get --no-act install xserver-xorg/xenial-proposed
Reading package lists... Done
Building dependency tree
Reading state information... Done
Selected version '1:7.7+12ubuntu1' (Ubuntu:16.04/xenial-proposed [amd64]) for 'xserver-xorg'
The following extra packages will be installed:
dbus keyboard-configuration libbsd0 libcap-ng0 libdbus-1-3 libdrm-amdgpu1 libdrm-intel1
libdrm-nouveau2 libdrm-radeon1 libdrm2 libedit2 libegl1-mesa libelf1 libepoxy0 libevdev2
libfontenc1 libfreetype6 libgbm1 libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libice6
libllvm3.6v5 liblocale-gettext-perl libmtdev1 libpam-systemd libpciaccess0 libpixman-1-0 libsm6
libtxc-dxtn-s2tc0 libwayland-client0 libwayland-server0 libx11-6 libx11-data libx11-xcb1
libxatracker2 libxau6 libxaw7 libxcb-dri2-0 libxcb-dri3-0 libxcb-glx0 libxcb-present0
libxcb-sync1 libxcb-util1 libxcb-xfixes0 libxcb1 libxcursor1 libxdamage1 libxdmcp6 libxext6
libxfixes3 libxfont1 libxi6 libxinerama1 libxkbfile1 libxmu6 libxmuu1 libxpm4 libxrandr2
libxrender1 libxshmfence1 libxt6 libxtst6 libxv1 libxvmc1 libxxf86vm1 x11-common x11-xkb-utils
xauth xfonts-base xfonts-encodings xfonts-utils xkb-data xserver-common xserver-xorg-core
xserver-xorg-input-all xserver-xorg-input-evdev xserver-xorg-input-mouse
xserver-xorg-input-synaptics xserver-xorg-input-vmmouse xserver-xorg-input-wacom
xserver-xorg-video-all xserver-xorg-video-ati xserver-xorg-video-cirrus xserver-xorg-video-fbdev
xserver-xorg-video-intel xserver-xorg-video-mach64 xserver-xorg-video-mga
xserver-xorg-video-neomagic xserver-xorg-video-nouveau xserver-xorg-video-openchrome
xserver-xorg-video-qxl xserver-xorg-video-r128 xserver-xorg-video-radeon
xserver-xorg-video-savage xserver-xorg-video-siliconmotion xserver-xorg-video-sisusb
xserver-xorg-video-tdfx xserver-xorg-video-trident xserver-xorg-video-vesa
xserver-xorg-video-vmware
Suggested packages:
dbus-user-session dbus-x11 pciutils xfs xserver xfonts-100dpi xfonts-75dpi xfonts-scalable
gpointing-device-settings touchfreeze xinput firmware-linux linux-firmware
Recommended packages:
xserver-xorg-video-modesetting
The following NEW packages will be installed:
dbus keyboard-configuration libbsd0 libcap-ng0 libdbus-1-3 libdrm-amdgpu1 libdrm-intel1
libdrm-nouveau2 libdrm-radeon1 libdrm2 libedit2 libegl1-mesa libelf1 libepoxy0 libevdev2
libfontenc1 libfreetype6 libgbm1 libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libice6
libllvm3.6v5 liblocale-gettext-perl libmtdev1 libpam-systemd libpciaccess0 libpixman-1-0 libsm6
libtxc-dxtn-s2tc0 libwayland-client0 libwayland-server0 libx11-6 libx11-data libx11-xcb1
libxatracker2 libxau6 libxaw7 libxcb-dri2-0 libxcb-dri3-0 libxcb-glx0 libxcb-present0
libxcb-sync1 libxcb-util1 libxcb-xfixes0 libxcb1 libxcursor1 libxdamage1 libxdmcp6 libxext6
libxfixes3 libxfont1 libxi6 libxinerama1 libxkbfile1 libxmu6 libxmuu1 libxpm4 libxrandr2
libxrender1 libxshmfence1 libxt6 libxtst6 libxv1 libxvmc1 libxxf86vm1 x11-common x11-xkb-utils
xauth xfonts-base xfonts-encodings xfonts-utils xkb-data xserver-common xserver-xorg
xserver-xorg-core xserver-xorg-input-all xserver-xorg-input-evdev xserver-xorg-input-mouse
xserver-xorg-input-synaptics xserver-xorg-input-vmmouse xserver-xorg-input-wacom
xserver-xorg-video-all xserver-xorg-video-ati xserver-xorg-video-cirrus xserver-xorg-video-fbdev
xserver-xorg-video-intel xserver-xorg-video-mach64 xserver-xorg-video-mga
xserver-xorg-video-neomagic xserver-xorg-video-nouveau xserver-xorg-video-openchrome
xserver-xorg-video-qxl xserver-xorg-video-r128 xserver-xorg-video-radeon
xserver-xorg-video-savage xserver-xorg-video-siliconmotion xserver-xorg-video-sisusb
xserver-xorg-video-tdfx xserver-xorg-video-trident xserver-xorg-video-vesa
xserver-xorg-video-vmware
0 upgraded, 102 newly installed, 0 to remove and 0 not upgraded.
Inst libbsd0 (0.7.0-2 Ubuntu:16.04/xenial [amd64])
Inst liblocale-gettext-perl (1.07-1 Ubuntu:16.04/xenial [amd64])
Inst libxau6 (1:1.0.8-1 Ubuntu:16.04/xenial [amd64])
Inst libxdmcp6 (1:1.1.2-1 Ubuntu:16.04/xenial [amd64])
Inst libxcb1 (1.11-0ubuntu1 Ubuntu:16.04/xenial [amd64])
Inst libx11-data (2:1.6.3-1ubuntu2 Ubuntu:16.04/xenial [all])
Inst libx11-6 (2:1.6.3-1ubuntu2 Ubuntu:16.04/xenial [amd64])
Inst libxext6 (2:1.3.3-1 Ubuntu:16.04/xenial [amd64])
Inst x11-common (1:7.7+7ubuntu4 Ubuntu:16.04/xenial [all])
Inst libice6 (2:1.0.9-1 Ubuntu:16.04/xenial [amd64])
Inst libmtdev1 (1.1.5-1ubuntu2 Ubuntu:16.04/xenial [amd64])
Inst libsm6 (2:1.2.2-1 Ubuntu:16.04/xenial [amd64])
Inst libxfixes3 (1:5.0.1-2 Ubuntu:16.04/xenial [amd64])
Inst libxrender1 (1:0.9.9-0ubuntu1 Ubuntu:16.04/xenial [amd64])
Inst libxcursor1 (1:1.1.14-1 Ubuntu:16.04/xenial [amd64])
Inst libxdamage1 (1:1.1.4-2 Ubuntu:16.04/xenial [amd64])
Inst libfontenc1 (1:1.1.3-1 Ubuntu:16.04/xenial [amd64])
Inst libfreetype6 (2.5.2-4ubuntu2 Ubuntu:16.04/xenial [amd64])
Inst libxfont1 (1:1.5.1-1 Ubuntu:16.04/xenial [amd64])
Inst libxinerama1 (2:1.1.3-1 Ubuntu:16.04/xenial [amd64])
Inst libxpm4 (1:3.5.11-1 Ubuntu:16.04/xenial [amd64])
Inst libxshmfence1 (1.2-1 Ubuntu:16.04/xenial [amd64])
Inst libxtst6 (2:1.2.2-1 Ubuntu:16.04/xenial [amd64])
Inst libxv1 (2:1.0.10-1 Ubuntu:16.04/xenial [amd64])
Inst libxxf86vm1 (1:1.1.4-1 Ubuntu:16.04/xenial [amd64])
Inst libtxc-dxtn-s2tc0 (0~git20131104-1.1 Ubuntu:16.04/xenial [amd64])
Inst keyboard-configuration (1.108ubuntu9 Ubuntu:16.04/xenial [all])
Inst xkb-data (2.12-1ubuntu1 Ubuntu:16.04/xenial [all])
Inst libcap-ng0 (0.7.7-1 Ubuntu:16.04/xenial [amd64])
Inst libdbus-1-3 (1.10.0-1ubuntu1 Ubuntu:16.04/xenial [amd64])
Inst dbus (1.10.0-1ubuntu1 Ubuntu:16.04/xenial [amd64])
Inst libdrm2 (2.4.65-3 Ubuntu:16.04/xenial [amd64])
Inst libedit2 (3.1-20150325-1ubuntu1 Ubuntu:16.04/xenial [amd64])
Inst libelf1 (0.163-5.1 Ubuntu:16.04/xenial [amd64])
Inst libxmuu1 (2:1.1.2-1ubuntu1 Ubuntu:16.04/xenial [amd64])
Inst xauth (1:1.0.9-1ubuntu2 Ubuntu:16.04/xenial [amd64])
Inst libdrm-amdgpu1 (2.4.65-3 Ubuntu:16.04/xenial [amd64])
Inst libpciaccess0 (0.13.4-1 Ubuntu:16.04/xenial [amd64])
Inst libdrm-intel1 (2.4.65-3 Ubuntu:16.04/xenial [amd64])
Inst libdrm-nouveau2 (2.4.65-3 Ubuntu:16.04/xenial [amd64])
Inst libdrm-radeon1 (2.4.65-3 Ubuntu:16.04/xenial [amd64])
Inst libwayland-client0 (1.9.0-1 Ubuntu:16.04/xenial [amd64])
Inst libwayland-server0 (1.9.0-1 Ubuntu:16.04/xenial [amd64])
Inst libllvm3.6v5 (1:3.6.2-3 Ubuntu:16.04/xenial [amd64])
Inst libgl1-mesa-dri (11.0.4-1ubuntu1 Ubuntu:16.04/xenial [amd64])
Inst libgbm1 (11.0.4-1ubuntu1 Ubuntu:16.04/xenial [amd64])
Inst libx11-xcb1 (2:1.6.3-1ubuntu2 Ubuntu:16.04/xenial [amd64])
Inst libxcb-dri2-0 (1.11-0ubuntu1 Ubuntu:16.04/xenial [amd64])
Inst libxcb-xfixes0 (1.11-0ubuntu1 Ubuntu:16.04/xenial [amd64])
Inst libegl1-mesa (11.0.4-1ubuntu1 Ubuntu:16.04/xenial [amd64])
Inst libepoxy0 (1.3.1-1 Ubuntu:16.04/xenial [amd64])
Inst libglapi-mesa (11.0.4-1ubuntu1 Ubuntu:16.04/xenial [amd64])
Inst libxcb-dri3-0 (1.11-0ubuntu1 Ubuntu:16.04/xenial [amd64])
Inst libxcb-glx0 (1.11-0ubuntu1 Ubuntu:16.04/xenial [amd64])
Inst libxcb-present0 (1.11-0ubuntu1 Ubuntu:16.04/xenial [amd64])
Inst libxcb-sync1 (1.11-0ubuntu1 Ubuntu:16.04/xenial [amd64])
Inst libgl1-mesa-glx (11.0.4-1ubuntu1 Ubuntu:16.04/xenial [amd64])
Inst libpam-systemd (227-2ubuntu1 Ubuntu:16.04/xenial [amd64])
Inst libpixman-1-0 (0.33.4-1 Ubuntu:16.04/xenial [amd64])
Inst libxatracker2 (11.0.4-1ubuntu1 Ubuntu:16.04/xenial [amd64])
Inst libxt6 (1:1.1.5-0ubuntu1 Ubuntu:16.04/xenial [amd64])
Inst libxmu6 (2:1.1.2-1ubuntu1 Ubuntu:16.04/xenial [amd64])
Inst libxaw7 (2:1.0.13-1 Ubuntu:16.04/xenial [amd64])
Inst libxi6 (2:1.7.5-1 Ubuntu:16.04/xenial [amd64])
Inst libxkbfile1 (1:1.0.9-0ubuntu1 Ubuntu:16.04/xenial [amd64])
Inst libxrandr2 (2:1.5.0-1 Ubuntu:16.04/xenial [amd64])
Inst libxvmc1 (2:1.0.9-1ubuntu1 Ubuntu:16.04/xenial [amd64])
Inst x11-xkb-utils (7.7+2 Ubuntu:16.04/xenial [amd64])
Inst xfonts-encodings (1:1.0.4-2 Ubuntu:16.04/xenial [all])
Inst xfonts-utils (1:7.7+3 Ubuntu:16.04/xenial [amd64])
Inst xfonts-base (1:1.0.4+nmu1 Ubuntu:16.04/xenial [all])
Inst xserver-common (2:1.17.3-2ubuntu1 Ubuntu:16.04/xenial-proposed [all])
Inst xserver-xorg-core (2:1.17.3-2ubuntu1 Ubuntu:16.04/xenial-proposed [amd64])
Inst libevdev2 (1.4.4+dfsg-1 Ubuntu:16.04/xenial [amd64])
Inst xserver-xorg-input-evdev (1:2.9.2-1ubuntu1 Ubuntu:16.04/xenial [amd64])
Inst xserver-xorg-input-mouse (1:1.9.1-1 Ubuntu:16.04/xenial [amd64])
Inst xserver-xorg-input-vmmouse (1:13.1.0-0ubuntu1 Ubuntu:16.04/xenial [amd64])
Inst xserver-xorg-input-synaptics (1.8.2-1ubuntu1 Ubuntu:16.04/xenial [amd64])
Inst xserver-xorg-input-wacom (1:0.30.0-0ubuntu3 Ubuntu:16.04/xenial [amd64])
Inst xserver-xorg-input-all (1:7.7+7ubuntu4 Ubuntu:16.04/xenial [amd64])
Inst xserver-xorg (1:7.7+12ubuntu1 Ubuntu:16.04/xenial-proposed [amd64])
Inst xserver-xorg-video-r128 (6.10.0-1 Ubuntu:16.04/xenial [amd64])
Inst xserver-xorg-video-mach64 (6.9.5-1 Ubuntu:16.04/xenial [amd64])
Inst xserver-xorg-video-radeon (1:7.5.0+git20150819-0ubuntu1 Ubuntu:16.04/xenial [amd64])
Inst xserver-xorg-video-ati (1:7.5.0+git20150819-0ubuntu1 Ubuntu:16.04/xenial [amd64])
Inst xserver-xorg-video-cirrus (1:1.5.3-1ubuntu1 Ubuntu:16.04/xenial [amd64])
Inst xserver-xorg-video-fbdev (1:0.4.4-1build3 Ubuntu:16.04/xenial [amd64])
Inst libxcb-util1 (0.4.0-0ubuntu3 Ubuntu:16.04/xenial [amd64])
Inst xserver-xorg-video-intel (2:2.99.917+git20151019-1~exp1ubuntu1 Ubuntu:16.04/xenial [amd64])
Inst xserver-xorg-video-mga (1:1.6.4-1 Ubuntu:16.04/xenial [amd64])
Inst xserver-xorg-video-neomagic (1:1.2.9-1 Ubuntu:16.04/xenial [amd64])
Inst xserver-xorg-video-nouveau (1:1.0.11-1ubuntu3 Ubuntu:16.04/xenial [amd64])
Inst xserver-xorg-video-openchrome (1:0.3.3-1ubuntu1 Ubuntu:16.04/xenial [amd64])
Inst xserver-xorg-video-savage (1:2.3.8-1ubuntu1 Ubuntu:16.04/xenial [amd64])
Inst xserver-xorg-video-siliconmotion (1:1.7.8-1ubuntu4 Ubuntu:16.04/xenial [amd64])
Inst xserver-xorg-video-sisusb (1:0.9.6-2build3 Ubuntu:16.04/xenial [amd64])
Inst xserver-xorg-video-tdfx (1:1.4.6-1 Ubuntu:16.04/xenial [amd64])
Inst xserver-xorg-video-trident (1:1.3.7-1 Ubuntu:16.04/xenial [amd64])
Inst xserver-xorg-video-vesa (1:2.3.4-0ubuntu1 Ubuntu:16.04/xenial [amd64])
Inst xserver-xorg-video-vmware (1:13.1.0-2ubuntu1 Ubuntu:16.04/xenial [amd64])
Inst xserver-xorg-video-all (1:7.7+7ubuntu4 Ubuntu:16.04/xenial [amd64])
Inst xserver-xorg-video-qxl (0.1.4-3ubuntu1 Ubuntu:16.04/xenial [amd64])
Conf libbsd0 (0.7.0-2 Ubuntu:16.04/xenial [amd64])
Conf liblocale-gettext-perl (1.07-1 Ubuntu:16.04/xenial [amd64])
Conf libxau6 (1:1.0.8-1 Ubuntu:16.04/xenial [amd64])
Conf libxdmcp6 (1:1.1.2-1 Ubuntu:16.04/xenial [amd64])
Conf libxcb1 (1.11-0ubuntu1 Ubuntu:16.04/xenial [amd64])
Conf libx11-data (2:1.6.3-1ubuntu2 Ubuntu:16.04/xenial [all])
Conf libx11-6 (2:1.6.3-1ubuntu2 Ubuntu:16.04/xenial [amd64])
Conf libxext6 (2:1.3.3-1 Ubuntu:16.04/xenial [amd64])
Conf x11-common (1:7.7+7ubuntu4 Ubuntu:16.04/xenial [all])
Conf libice6 (2:1.0.9-1 Ubuntu:16.04/xenial [amd64])
Conf libmtdev1 (1.1.5-1ubuntu2 Ubuntu:16.04/xenial [amd64])
Conf libsm6 (2:1.2.2-1 Ubuntu:16.04/xenial [amd64])
Conf libxfixes3 (1:5.0.1-2 Ubuntu:16.04/xenial [amd64])
Conf libxrender1 (1:0.9.9-0ubuntu1 Ubuntu:16.04/xenial [amd64])
Conf libxcursor1 (1:1.1.14-1 Ubuntu:16.04/xenial [amd64])
Conf libxdamage1 (1:1.1.4-2 Ubuntu:16.04/xenial [amd64])
Conf libfontenc1 (1:1.1.3-1 Ubuntu:16.04/xenial [amd64])
Conf libfreetype6 (2.5.2-4ubuntu2 Ubuntu:16.04/xenial [amd64])
Conf libxfont1 (1:1.5.1-1 Ubuntu:16.04/xenial [amd64])
Conf libxinerama1 (2:1.1.3-1 Ubuntu:16.04/xenial [amd64])
Conf libxpm4 (1:3.5.11-1 Ubuntu:16.04/xenial [amd64])
Conf libxshmfence1 (1.2-1 Ubuntu:16.04/xenial [amd64])
Conf libxtst6 (2:1.2.2-1 Ubuntu:16.04/xenial [amd64])
Conf libxv1 (2:1.0.10-1 Ubuntu:16.04/xenial [amd64])
Conf libxxf86vm1 (1:1.1.4-1 Ubuntu:16.04/xenial [amd64])
Conf libtxc-dxtn-s2tc0 (0~git20131104-1.1 Ubuntu:16.04/xenial [amd64])
Conf keyboard-configuration (1.108ubuntu9 Ubuntu:16.04/xenial [all])
Conf xkb-data (2.12-1ubuntu1 Ubuntu:16.04/xenial [all])
Conf libcap-ng0 (0.7.7-1 Ubuntu:16.04/xenial [amd64])
Conf libdbus-1-3 (1.10.0-1ubuntu1 Ubuntu:16.04/xenial [amd64])
Conf dbus (1.10.0-1ubuntu1 Ubuntu:16.04/xenial [amd64])
Conf libdrm2 (2.4.65-3 Ubuntu:16.04/xenial [amd64])
Conf libedit2 (3.1-20150325-1ubuntu1 Ubuntu:16.04/xenial [amd64])
Conf libelf1 (0.163-5.1 Ubuntu:16.04/xenial [amd64])
Conf libxmuu1 (2:1.1.2-1ubuntu1 Ubuntu:16.04/xenial [amd64])
Conf xauth (1:1.0.9-1ubuntu2 Ubuntu:16.04/xenial [amd64])
Conf libdrm-amdgpu1 (2.4.65-3 Ubuntu:16.04/xenial [amd64])
Conf libpciaccess0 (0.13.4-1 Ubuntu:16.04/xenial [amd64])
Conf libdrm-intel1 (2.4.65-3 Ubuntu:16.04/xenial [amd64])
Conf libdrm-nouveau2 (2.4.65-3 Ubuntu:16.04/xenial [amd64])
Conf libdrm-radeon1 (2.4.65-3 Ubuntu:16.04/xenial [amd64])
Conf libwayland-client0 (1.9.0-1 Ubuntu:16.04/xenial [amd64])
Conf libwayland-server0 (1.9.0-1 Ubuntu:16.04/xenial [amd64])
Conf libllvm3.6v5 (1:3.6.2-3 Ubuntu:16.04/xenial [amd64])
Conf libgl1-mesa-dri (11.0.4-1ubuntu1 Ubuntu:16.04/xenial [amd64])
Conf libgbm1 (11.0.4-1ubuntu1 Ubuntu:16.04/xenial [amd64])
Conf libx11-xcb1 (2:1.6.3-1ubuntu2 Ubuntu:16.04/xenial [amd64])
Conf libxcb-dri2-0 (1.11-0ubuntu1 Ubuntu:16.04/xenial [amd64])
Conf libxcb-xfixes0 (1.11-0ubuntu1 Ubuntu:16.04/xenial [amd64])
Conf libegl1-mesa (11.0.4-1ubuntu1 Ubuntu:16.04/xenial [amd64])
Conf libepoxy0 (1.3.1-1 Ubuntu:16.04/xenial [amd64])
Conf libglapi-mesa (11.0.4-1ubuntu1 Ubuntu:16.04/xenial [amd64])
Conf libxcb-dri3-0 (1.11-0ubuntu1 Ubuntu:16.04/xenial [amd64])
Conf libxcb-glx0 (1.11-0ubuntu1 Ubuntu:16.04/xenial [amd64])
Conf libxcb-present0 (1.11-0ubuntu1 Ubuntu:16.04/xenial [amd64])
Conf libxcb-sync1 (1.11-0ubuntu1 Ubuntu:16.04/xenial [amd64])
Conf libgl1-mesa-glx (11.0.4-1ubuntu1 Ubuntu:16.04/xenial [amd64])
Conf libpam-systemd (227-2ubuntu1 Ubuntu:16.04/xenial [amd64])
Conf libpixman-1-0 (0.33.4-1 Ubuntu:16.04/xenial [amd64])
Conf libxatracker2 (11.0.4-1ubuntu1 Ubuntu:16.04/xenial [amd64])
Conf libxt6 (1:1.1.5-0ubuntu1 Ubuntu:16.04/xenial [amd64])
Conf libxmu6 (2:1.1.2-1ubuntu1 Ubuntu:16.04/xenial [amd64])
Conf libxaw7 (2:1.0.13-1 Ubuntu:16.04/xenial [amd64])
Conf libxi6 (2:1.7.5-1 Ubuntu:16.04/xenial [amd64])
Conf libxkbfile1 (1:1.0.9-0ubuntu1 Ubuntu:16.04/xenial [amd64])
Conf libxrandr2 (2:1.5.0-1 Ubuntu:16.04/xenial [amd64])
Conf libxvmc1 (2:1.0.9-1ubuntu1 Ubuntu:16.04/xenial [amd64])
Conf x11-xkb-utils (7.7+2 Ubuntu:16.04/xenial [amd64])
Conf xfonts-encodings (1:1.0.4-2 Ubuntu:16.04/xenial [all])
Conf xfonts-utils (1:7.7+3 Ubuntu:16.04/xenial [amd64])
Conf xfonts-base (1:1.0.4+nmu1 Ubuntu:16.04/xenial [all])
Conf xserver-common (2:1.17.3-2ubuntu1 Ubuntu:16.04/xenial-proposed [all])
Conf xserver-xorg-core (2:1.17.3-2ubuntu1 Ubuntu:16.04/xenial-proposed [amd64])
Conf libevdev2 (1.4.4+dfsg-1 Ubuntu:16.04/xenial [amd64])
Conf xserver-xorg-input-evdev (1:2.9.2-1ubuntu1 Ubuntu:16.04/xenial [amd64])
Conf xserver-xorg-input-mouse (1:1.9.1-1 Ubuntu:16.04/xenial [amd64])
Conf xserver-xorg-input-vmmouse (1:13.1.0-0ubuntu1 Ubuntu:16.04/xenial [amd64])
Conf xserver-xorg-input-synaptics (1.8.2-1ubuntu1 Ubuntu:16.04/xenial [amd64])
Conf xserver-xorg-input-wacom (1:0.30.0-0ubuntu3 Ubuntu:16.04/xenial [amd64])
Conf xserver-xorg-input-all (1:7.7+7ubuntu4 Ubuntu:16.04/xenial [amd64])
Conf xserver-xorg (1:7.7+12ubuntu1 Ubuntu:16.04/xenial-proposed [amd64])
Conf xserver-xorg-video-r128 (6.10.0-1 Ubuntu:16.04/xenial [amd64])
Conf xserver-xorg-video-mach64 (6.9.5-1 Ubuntu:16.04/xenial [amd64])
Conf xserver-xorg-video-radeon (1:7.5.0+git20150819-0ubuntu1 Ubuntu:16.04/xenial [amd64])
Conf xserver-xorg-video-ati (1:7.5.0+git20150819-0ubuntu1 Ubuntu:16.04/xenial [amd64])
Conf xserver-xorg-video-cirrus (1:1.5.3-1ubuntu1 Ubuntu:16.04/xenial [amd64])
Conf xserver-xorg-video-fbdev (1:0.4.4-1build3 Ubuntu:16.04/xenial [amd64])
Conf libxcb-util1 (0.4.0-0ubuntu3 Ubuntu:16.04/xenial [amd64])
Conf xserver-xorg-video-intel (2:2.99.917+git20151019-1~exp1ubuntu1 Ubuntu:16.04/xenial [amd64])
Conf xserver-xorg-video-mga (1:1.6.4-1 Ubuntu:16.04/xenial [amd64])
Conf xserver-xorg-video-neomagic (1:1.2.9-1 Ubuntu:16.04/xenial [amd64])
Conf xserver-xorg-video-nouveau (1:1.0.11-1ubuntu3 Ubuntu:16.04/xenial [amd64])
Conf xserver-xorg-video-openchrome (1:0.3.3-1ubuntu1 Ubuntu:16.04/xenial [amd64])
Conf xserver-xorg-video-savage (1:2.3.8-1ubuntu1 Ubuntu:16.04/xenial [amd64])
Conf xserver-xorg-video-siliconmotion (1:1.7.8-1ubuntu4 Ubuntu:16.04/xenial [amd64])
Conf xserver-xorg-video-sisusb (1:0.9.6-2build3 Ubuntu:16.04/xenial [amd64])
Conf xserver-xorg-video-tdfx (1:1.4.6-1 Ubuntu:16.04/xenial [amd64])
Conf xserver-xorg-video-trident (1:1.3.7-1 Ubuntu:16.04/xenial [amd64])
Conf xserver-xorg-video-vesa (1:2.3.4-0ubuntu1 Ubuntu:16.04/xenial [amd64])
Conf xserver-xorg-video-vmware (1:13.1.0-2ubuntu1 Ubuntu:16.04/xenial [amd64])
Conf xserver-xorg-video-all (1:7.7+7ubuntu4 Ubuntu:16.04/xenial [amd64])
Conf xserver-xorg-video-qxl (0.1.4-3ubuntu1 Ubuntu:16.04/xenial [amd64])
(wily-amd64)[email protected]:~#


--
ubuntu-devel mailing list
[email protected]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel