Sunday, 10 September 2017

Re: Compressed apt index files by default for 18.04?

On Sun, Sep 10, 2017 at 11:42:59AM +0200, Julian Andres Klode wrote:
> On Sun, Sep 10, 2017 at 10:01:27AM +0100, Colin Watson wrote:
> > On Sat, Sep 09, 2017 at 04:41:27PM +0200, Julian Andres Klode wrote:
> > > I'd like us to try out using LZ4 compressed index files in
> > > /var/lib/apt/lists for 18.04, starting from the beginning
> > > of the development period with apt 1.6~alpha1 (ASAP).
> > >
> > > This is done by swapping the default for Acquire::gzipIndexes
> > > from false to true.
> > >
> > > On my (Debian) system, this compresses /var/lib/apt/lists
> > > from 1.3 GB down to 241 MB, which is a lot of space.
> > >
> > > There are some packages broken with this, I just started
> > > a mass bug filing in Debian for that purpose.
> >
> > Note that we'd need to get
> > https://code.launchpad.net/~cjwatson/launchpad-buildd/apt-lists/+merge/286751
> > reviewed and landed before doing this, or dep-wait analysis of failed
> > builds will break.
>
> I should mention that you don't need apt-helper, but can just pass
> a file name to apt_pkg.TagFile and it handles decompression, starting
> with libapt-pkg4.12 (which is about apt 1.0.9 I think?).

And well, python-apt version needs to be >= 0.8.3ubuntu4 for compressed
file support as well. We somehow forgot to advertise it, but it's there
since precise.

--
Debian Developer - deb.li/jak | jak-linux.org - free software dev
| Ubuntu Core Developer |
When replying, only quote what is necessary, and write each reply
directly below the part(s) it pertains to ('inline'). Thank you.

--
ubuntu-devel mailing list
[email protected]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel