Friday, 31 July 2020

+1 maintenance report

Here's some of the things I worked on for my +1 maintenance this week.

* Packages where only a single arch failed, I retriggered test runs.
Many of these required additional triggers to include icu, gcc-10, etc.
- sleekxmpp
- jinja2
- lua-luv
- libhttp-dav-perl
- node-jquery
- gegl
- bluez-qt
- Bunch more, lost track...

* Went through packages listing 'missing builds' and re-triggered
ones where the logs showed connection errors or other irregularities
that might be build system errors. Quite a few of these passed.

* Rebuilt / retested all packages with a riscv failure more than 30 days
old. It's relatively new, figured things change fast. Over half of
these passed.

* php-horde-*: Most of this stack has been blocked from being synced,
but there were four more trying to sync. These four are added now.
(If any other php-horde-* packages show up, please add them as well.)

* openclipart: Debian is on libreoffice 7.x but we're on 6.x;
openclipart was trying to depend on a new binary package from 7.x. I
restored that back to the 6.x-era dependency, and this migrated.

* nodejs: There was a syntax warning in an awk statement that was
causing the autopkgtest's lint check to fail. I fixed the warning;
hopefully it will pass now.

* node-*: There were numerous autopkgtest regressions that were fixed by
re-triggering against nodejs, icu, pegjs and various combinations of other
- node-chokidar
- node-formidable
- node-json-buffer
- node-kew
- node-clean-css
- node-oauth-sign
- node-opencv

### Still Needing Attention ###

Some notes for remaining work:

* node-node-sass: Hits a TypeError, still needs investigated.

* node-sha.js, node-create-hash, node-crypto-browserfy:
- See LP: #1887144

* node-xterm: I think this needs updated to 4.x (see deb #964170).
Debian (and Ubuntu) are on 3.8. There seems to be some type conflict
between Window and DOMWindow; might be due to API changes in nodejs?

* python-hypothesis: It errors on unreliable test timings. The package
seems to have a history of this. I retried a couple times, but maybe
the test should be skipped as flaky?

* gubbins: This is being built on arch: All, but depends on iqtree which
is built only for a few arch's, so gubbins fails on other arch's. I
tried building iqtree with arch: All but no such luck. Not sure what
to do here...

ubuntu-devel mailing list
Modify settings or unsubscribe at: