Tuesday, 11 March 2014

Re: Aiming for Qemu 2.0 in 14.04

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iQIcBAEBCgAGBQJTHz1NAAoJEFHb3FjMVZVzGnkP/RT8+Q47/lPg7shrm/81tt/m
hIJf6VPbrWxAeiLM+xgT75b0b4PAQkIarRTNmipyggr5ku6olLoNXfcyGDOODiLy
CdF+tf4+nyc72C8PoWP3W+ECsoxQ9KX1lYnM6kUl/Wgpj9VN7ohy9SBEJaPjgWJH
e5YPRjMPPfESal0cu4bF04U7WhywuY82hBqU9o+pUddctrEFGqIqCdEqIPqutkoh
+l/ry3vz+dmjuEayz6MrPdk1UZLMg2YDYbQm0h1vV8S0U/Lad2FJuK3lB7D0XURU
k4JuBEQvQGRzltcNfhUDMIMVUWOhGT2KFO5L8rCBA7lYaIIRwiXQa2m6uGj69ywm
3gBhP3xSMnw1dICr5ZJ/68V6e0ZKjifiAIXN8YqBW+VmDrx6F3WCcGdZp2ipDWI3
ytATY2+m6bE0RiIw7AH8fU4hTIqNh9UuyuglzDGYlwU9OhPuUIlGHNT6JTAM5gkA
DmsrSpaCxPBpPXz1rsPY+sDiIugkBgCqRYi+gon3ZwsOkZWHSPX2JzQKu8srzjYm
2fSJCPC1UMjcaGtCVaT5bgAE9mMVCpLkG+fNYN/zTWsw7jaAKiQu0zXK5UF3kObu
pV+ZBdKVJPLYp1B+THdbTqhguLrT6N8gj9/gYQJ4/7nIRIKFMMTZU4PKlZeIk3y8
M40FqxGdW1aNSjQlTCjQ
=YXTp
-----END PGP SIGNATURE-----
On 02/26/2014 12:40 PM, Serge Hallyn wrote:
> Hi,
>
> as shown https://bugs.launchpad.net/ubuntu/+source/qemu/+bug/1284793
> we are hoping to get Qemu 2.0 into 14.04. This is tricky due to
> the timing - Qemu 2.0 release is scheduled for April 4
> ( http://wiki.qemu.org/Planning/2.0 ), with freeze for 14.04 being
> April 10. However, the drastic reduction in patches carried in
> the package, given the length of the LTS cycle, would be worthwhile.
>
> In an attempt to shake out bugs as early as possible, I've started
> building packages based on current git HEAD at ppa:ubuntu-virt/candidate.
> This seems to be testing quite well for me on amd64. It would be
> great if people could start testing the version in this ppa where
> possible, as early as possible.
>
> If we do run into bugs, we can hopefully get them fixed upstream before
> release. If we can't get them fixed, then we'll know to stick with the
> 1.7 based qemu for 14.04.
>

Seems that libvirt snapshots are not working correctly with
2.0~git-20140307.4c288ac-0ubuntu2. Eg:

$ virsh snapshot-create-as test-saucy-amd64 pristine "uvt snapshot"
error: internal error: Child process (/usr/bin/kvm-img snapshot -c pristine
/home/jamie/vms/machines/test-saucy-amd64.qcow2) unexpected exit status 1:
libvirt: error : cannot execute binary /usr/bin/kvm-img: No such file or directory

/usr/bin/kvm-img used to be part of qemu-utils, but
2.0~git-20140307.4c288ac-0ubuntu2 doesn't ship it.

Creating a symlink to /usr/bin/qemu-img from /usr/bin/kvm-img makes this error
go away and things seem to work, but I've not reviewed/tested if this is the
correct fix.

--
Jamie Strandboge http://www.ubuntu.com/