Thursday, 1 May 2014

Re: GnuTLS 2.8 transition for Unicorns

Hi Dimitri,

On Thu, May 01, 2014 at 09:50:29PM +0100, Dimitri John Ledkov wrote:
> GMP in unicorn is now dual licensed under LGPLv3+ & GPLv2+ [1], thus
> software only needs to be compatible with GPLv2 to link against
> gnutls28.

> Should we transition to gnutls28 by default?
> Should we only have gnutls28 in main?

Yes and yes.

I imagine this transition should probably be coordinated in Debian first.
I've seen the announcement there about the license change, but haven't seen
any coordination of a transition yet, do you know if this is being done?

Thanks,
--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
[email protected] [email protected]